composer的安装:linux下Composer的安装

对于现代语言而言,包管理器基本上是标配。Java有Maven,Python有pip,Ruby有gem,Nodejs有npm。PHP的是PEAR,不过据说pear不咋的,好在目前我们有Composer,PHP依赖管理的利器。它是开源的,使用起来也很简单,提交自己的包也很容易。

在linux下的安装方式为:

执行命令:
1.png

国内互联网某种神秘的力量让Composer变得越来越不稳定。 如果此种情况已经严重影响您的心情,你可以使用以下命令安装:
2.png

注:这个命令会将composer.phar下载到当前目录。PHAR(PHP 压缩包)是一个压缩格式,可以在命令行下直接运行。

然后执行命令:
3.png

这样其实就安装好了,不过说一点,Composer需要PHP 5.3.2+才能运行。

修改镜像前需要找到config.json配置文件,执行如下命令:
4.png

然后找到[home]项,一般默认是/root/.composer/目录,那么就可以编辑他
5.png

为了避免安装包的时候都要执行两次查询,切记要添加禁用 packagist 的设置
6.png

或者使用这个镜像:
7.png

比如我最后的配置如下:

8.png
然后更新一下composer

9.png

关注友儿不迷路

Last modification:August 16th, 2019 at 11:53 am
如果觉得我的文章对你有用,请随意赞赏